fiduciary

Author Topic: CFX Sound Fonts  (Read 828 times)

0 Members and 1 Guest are viewing this topic.

Offline Prestwn

  • No Force
  • *
  • Posts: 10
  • Hello there!
CFX Sound Fonts
« on: August 14, 2020, 08:15:34 PM »
Hey everyone.  I got my saber up and running and am now trying to add a new sound font to the CFX board.  I followed Plector Lab's manual and although the saber ignites and I can cycle through the new font, it doesn't play any of the new sounds.  The font folder has the font_config.txt and leds.txt files, and I matched the  naming format of the other font folders (boot.wav, swing1.wav, etc.).  The new sound fonts have bit rates over 300kbps.  Most of the old sounds were deleted, but I filled the gaps with some of the older sounds.  The older sounds (copied from a default font folder) will play, but the new ones won't. 

Any ideas on what I'm missing?

Thanks!

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4835
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: CFX Sound Fonts
« Reply #1 on: August 15, 2020, 12:55:18 AM »
Sample rate or format is probably incorrect in your sound files. Ensure 22050 or 44100 files.
Logs will probably tell you you as well.

Offline Prestwn

  • No Force
  • *
  • Posts: 10
  • Hello there!
Re: CFX Sound Fonts
« Reply #2 on: August 15, 2020, 01:56:15 PM »
Thanks. I found an older post showing how to make the sample rate 22050 and 16 bit. That works on some files but not others, which is strange.

I noticed some sound clips have track numbers. Any idea if that has an impact? The titles are all formatted correctly.

Sorry, I'm new to these terms! But thanks for all the help, I'm getting there slowly but surely!

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4835
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: CFX Sound Fonts
« Reply #3 on: August 15, 2020, 11:12:44 PM »
If certain sound files don't play their naming or format is incorrect