fiduciary

Author Topic: No NEOPIXEL  (Read 554 times)

0 Members and 2 Guests are viewing this topic.

Offline Darth_Muppet

  • No Force
  • *
  • Posts: 3
  • Um...Hello?
No NEOPIXEL
« on: October 27, 2019, 12:10:42 AM »
Complete newbie to Saber building so please bear with me.

Im constructing a Wattos Junkyard DARK LORD sabre with a 132 neopixel blade to a Shtok CustomWorx NPXL NeoPixel LED Connector PCB Kit - LONG PINS all connected to a Plecter Crystal Shard v4 with the 4.5 upgrade (so it can run Neopixel)

Hilt powers up fine, got sound and motion but absolutely no lights at all on the blade or the hilt. Have checked the wiring, no broken wires or shorts.

Had a look at the config file but cannot fine anything there that defines the led blade led length (I believe there should be). Could it be that thats the problem?

Going to remove the tiny resistor and chage to an inline resistor and try it again today to see if that makes a difference.


Online K-2SO

  • Killer Droid Extraordinaire
  • Administrator
  • Master Force User
  • *
  • Posts: 990
  • Congratulations! You are being rescued.
Re: No NEOPIXEL
« Reply #1 on: October 27, 2019, 12:26:21 AM »
You would have to make sure you have the config files for the CS4.5 and NOT the CS4.0. Also, which battery are you using?

I find your arguments vague and unconvincing.

Quiet! *Slap* And there’s a fresh one if you mouth off again.

Offline Darth_Muppet

  • No Force
  • *
  • Posts: 3
  • Um...Hello?
Re: No NEOPIXEL
« Reply #2 on: October 27, 2019, 02:48:34 AM »
Keeppower 3.7v 3120mah 15A High Drain PCB Protected Removable Lithium Ion Battery

I couldnt find a V4 board manual, so had to base it on the V3 crystal shard. Had a look on the PlecterLabs site but cannot see a default config for the 4.5

« Last Edit: October 27, 2019, 02:53:13 AM by Darth_Muppet »

Offline QUI-GON JINN

  • Also known as Jay-gon Jinn!
  • JEDI/ALLIANCE Master MODERATOR
  • Master Force User
  • **
  • Posts: 8397
  • Your focus determines your reality
Re: No NEOPIXEL
« Reply #3 on: October 27, 2019, 07:48:38 AM »
Keeppower 3.7v 3120mah 15A High Drain PCB Protected Removable Lithium Ion Battery

I couldnt find a V4 board manual, so had to base it on the V3 crystal shard. Had a look on the PlecterLabs site but cannot see a default config for the 4.5
Default package for the CS 4.5 can be found here: Article Info - Plecter Labs - Props Electronics This includes the configuration file necessary for neopixel setups.
« Last Edit: October 27, 2019, 07:52:26 AM by QUI-GON JINN »


Offline eastern57

  • Neato Jedi Knight
  • Master Force User
  • *****
  • Posts: 1307
Re: No NEOPIXEL
« Reply #4 on: October 27, 2019, 09:10:09 AM »
Check the Override file.  The parameter for neopixel blade length is put in there by default.  It should be "ledstrip=132."

Offline Darth_Muppet

  • No Force
  • *
  • Posts: 3
  • Um...Hello?
Re: No NEOPIXEL
« Reply #5 on: October 28, 2019, 02:38:53 AM »
Thank you.

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4421
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: No NEOPIXEL
« Reply #6 on: October 28, 2019, 02:44:10 AM »
also, eventually post pics of your board top and bottom so that I check the CS4.5 has been correctly patched for ledstrip operation