fiduciary

Author Topic: Crystal Focus X (v10) specs, demo and discussion  (Read 60109 times)

0 Members and 1 Guest are viewing this topic.

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #105 on: November 11, 2019, 11:35:43 PM »
thanks a lot for the testing and feedback ! yes, I just coded it this way but you are right, it would be better to have only act. bring the quick ignite. Probably an easy mod for this morning, as I'm returning to work.
That's definitely the usage / use cases tests I'm after, because I can't test or play with all of the combinations, even with a saber in hand, it has a lot to do with specific configurations from the users ! (cheers)

Offline JediJesseS

  • Trade Count: (0)
  • No Force
  • *
  • Posts: 6
  • Um...Hello?
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #106 on: November 12, 2019, 03:37:58 PM »
Hello, I've tested the board on three different Windows 10 machines and the problem remains exactly the same on each. Failed device descriptor. I'm not sure if this would help diagnose the issue but I also have a problem with excessive power draw. Even though the board seems to go into deep sleep mode (settings correct for sleep and deep - activation switch press is needed to wake the board) if left overnight without charging the board will be dead by the next day. You will have a much better idea of whether these issues could be related at all. I've attached a picture of the board but there is a Sabertrio sticker over some of the area. Let me know if there are any additional diagnostic measures I can look into. Thank you for your help!

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #107 on: November 12, 2019, 10:08:43 PM »
Based on the chassis install I can't see the MCU side of the USB wiring but the port looks ok and soldering too. If you have over consumption issue, there might be a bridge somewhere in the install or on the board.
I suggest you contact sabertrio about this because I don't see other things to test, especially if you're not touching the install itself (chassis etc) which is totally understandable.
Could you eventually have a look to the latest version of the manual and locate the voltage map and check the audio amp +5V and the aux 3.3V, both are accessible on your board without disassembling. Ideally the permanent +3.3V as well but I can't see on the pic if you can probe it.

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #108 on: November 15, 2019, 12:04:46 AM »
still feeling quite low and in the recovery "back draft"  :embarrassed: I got warned that I would get a quick "high" after the surgery, then a little low after (scar tissues reforming and healing uses energy). Coding, but not as much as I'd want.
As mentioned on social media, I've well started deconstructing existing code for timeline and aux. ledstrip output to get this totally modular, some good progress. Overall, some of that code got inherited from prizm and CS (for the ledstrip aspect) and just got ported to C++ to get it to work with the CFX arch but didn't get much effort to refactor it (I can do so many things, right?  :angel:). Full day coding today and customers got taken care of yesterday, so I can move to this, will post a quick demo as soon as it works !

Offline pwrmac7600

  • Trade Count: (0)
  • No Force
  • *
  • Posts: 11
  • Um...Hello?
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #109 on: November 25, 2019, 02:18:14 PM »
Any near future plans for adding more blade style options?
plans to add items like localized lockup?
Something that would put the CFX on a more even playing field effects wise with proffie?

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #110 on: November 25, 2019, 09:27:50 PM »
Certainly, yes. Updates posted on social media, blade structure redone and former cs/primz code gone. Integrated power on-off styles and i'm now adding fx styles (lockup included).
I also need to finish single switch operation.

Offline pwrmac7600

  • Trade Count: (0)
  • No Force
  • *
  • Posts: 11
  • Um...Hello?
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #111 on: November 26, 2019, 02:35:40 PM »
Certainly, yes. Updates posted on social media, blade structure redone and former cs/primz code gone. Integrated power on-off styles and i'm now adding fx styles (lockup included).
I also need to finish single switch operation.

Awesome to hear! Unfortunately I closed out all of my social media accounts years ago. and swore them off for good. lol
now just doing the old fashion message board thing.
But thank you for the update.

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #112 on: November 26, 2019, 09:36:08 PM »
NP, I try to combo-post things here as well and I like what forums have to offer !

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #113 on: December 01, 2019, 11:27:49 PM »
Since Tatsuo posted a question about those on FB, I though I would make a quick video about those micro pixel. I sourced those about 6 months ago and mockup a quick PCB for them with the idea in mind to make a pixel accent demo with them. I first spider-wired one with thin wire as you can spot on the first picture :-)
Those are 2020 SMD package (20x20 mil) pixels. Enjoy !





Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #114 on: December 02, 2019, 09:44:43 PM »
though it's (linked) in the manual (current version), I realize I haven't posted the video for FW upgrade on CFX using a serial terminal (dockligh on PC in my case). You can now do pretty much the same with RICE using the serial log area below the remote control buttons.


Offline J.E.D., I

  • Trade Count: (0)
  • No Force
  • *
  • Posts: 7
  • Um...Hello?
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #115 on: December 06, 2019, 02:06:26 PM »
Hello All,

I have a couple questions about magic activation. I calibrated my saber like the CFX manual instructed--my magic score was 350.

Is that to low? Did I do something wrong?

Assuming everthing was ok, I then changed Saber Lock to 1 and put the magic threshold at 350. This was all in profile 0. No luck--I tried every profile. Did I do something wrong? What is profile 0?

Thanks

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #116 on: December 06, 2019, 10:14:55 PM »
the magic score give you the magnetic "situation" with nothing magnetic around aside what the saber is made of (hilt, speaker, battery etc).
350 is really low !
Did you log the calibration process via USB to see if the sensor was actually changing ?

Still, that situation at "rest" isn't the threshold. I usually put a threshold of about 20000. Start without using saberlock and magic only to see if you can get an activation. Keep in mind that saber lock needs the mag score to go < 0.5*the magic threshold to have the lock/unlock state machine to work correctly.
you can also use the serial commands logmagic and getfield to double check the sensor is working as expected.

Offline Ridire Fíréan

  • Trade Count: (0)
  • Force User
  • ***
  • Posts: 103
  • Up&down&around the bend a Jedi's story never ends
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #117 on: December 10, 2019, 04:37:38 PM »
Hey @erv  !  In the past (CF-8/CF-9) with a 2W speaker it didn't matter what pad was wired to whatever speaker solder tab.

With the new CF-X, and with a 3W WOW Sound Speaker that has a Positive Solder Tab, does it matter which CF-X speaker pad the positive side speaker solder tab is connected to?

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Trade Count: (0)
  • Master Force User
  • *
  • Posts: 4691
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #118 on: December 10, 2019, 10:22:38 PM »
Individual speaker doesn't have a polarity. Used only for phase match with multiple speakers.

Offline MikeyX

  • Trade Count: (0)
  • Force User
  • ***
  • Posts: 202
  • Star Wars collector in the UK.
Re: Crystal Focus X (v10) specs, demo and discussion
« Reply #119 on: December 24, 2019, 01:07:53 PM »
I have a problem with the new 10.002Beta firmware - it's probably just me missing something obvious, but I can't figure it out.

I updated a NeoPixel saber to 10.002Beta without issue, including getting my head around all the new parameters. I like some of the new features including the begin/end drags, and the begin lock, also the ability to get multiple force and force clashes. qon/qoff being per font is also finally fixed :smiley: - everything worked fine.

Then today I updated a High Power LED saber and hit a problem. The settings are pretty much out of the box from the new default package. Ledstrip=0 so it should be in HP LED mode. However the saber fires up fine in terms of sound, but the LEDs are all completely dead whatever blade or color profile I'm using. I couldn't get the main blade LEDs to fire up whatever I did. I've reverted to the 10.001Beta FW (and back to the old settings) and everything works fine again. Are there any settings that I'm missing that could disable the HP LED blade?