fiduciary

Author Topic: SOLVED: Nano Biscotte v4: Random LED glow and speaker pops when untouched.  (Read 673 times)

0 Members and 1 Guest are viewing this topic.

Offline Moxized

  • No Force
  • *
  • Posts: 12
  • My other lightsaber is an axe.
I agree.

I've gone ahead and resoldered and this time added heat shrink that I shoved up through the eyes of the heatsync pushing right up to the solder joint, l'll put things back together outside the hilt tonight and let it run for 3 minutes then turn it off and just let it sit on my table to see how it acts turning it off and on with more resting periods.

Maybe I'll goof around with the old Nbv4 to see if I can bring it back to life. Make myself an excuse to find it a home in another build :grin:

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4322
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Maybe I'll goof around with the old Nbv4 to see if I can bring it back to life. Make myself an excuse to find it a home in another build :grin:

you can always PM chewbacca here to have it repaired. Our boards are easily serviceable !

Offline Moxized

  • No Force
  • *
  • Posts: 12
  • My other lightsaber is an axe.
Hoping I don't jinx anything. So far there has been no issues, since I redid the Tri-Cree soldering and used heatshrink tubing pushed up on each wire to the solderjoint, I've not had any issues. Multiple uses and battery swaps.

Also the new 2watt resistors were a good change too, they get hot, but not stupid hot that they are melting nearby wires and plastic like the three 3watt resistors did.

I think the next build I will go the route of a charge port and kill key

Thanks again to everyone who helped out.