fiduciary

Author Topic: Prizm 5.1 Neopixel help.  (Read 131 times)

0 Members and 1 Guest are viewing this topic.

Offline Ztrox93

  • No Force
  • *
  • Posts: 6
  • Um...Hello?
Prizm 5.1 Neopixel help.
« on: November 08, 2017, 09:06:09 PM »
]Hello there!

So I am trying to finish my saber, and I cannot get it to work.

-2x WS2812B neopixel strips
-1x 18650 battery (Since I am not using a charge port, I am going upgrade to a high drain battery)
-1x 2w speaker 8 ohm
-2x SPST Momentary tactile switch
-1x PRIZM 5.1
-1x 4.7k resistor (This is going to be changed to a 470 ohm resistor)

-I wired everything up, checked the connections, added my resistor, popped in the battery, then the SD card, pressed the buttons, and nothing happened. I figured it was either the way I wired my switches, or maybe the SD card is not configured correctly. I don't understand why I'm not at least getting sound. I plugged the blade in after to see if it would activate, no dice there as well.

-When configuring the SD do I need to place the overide text folder into the profile folders? Or will it be set for all of the profiles? I was confused on this part while reading the instruction manual, and I couldn't find anything online about how to set this up. Is there a video on how to configure this without the RICE port?

Any ideas would be so appreciated I cannot wait for this to be completed!

Thank you!

I have attached a diagram of my wiring, the wiring, and a picture of my wiring to the switches.

Imgur: The most awesome images on the Internet
Imgur: The most awesome images on the Internet
Imgur: The most awesome images on the Internet
Imgur: The most awesome images on the Internet
« Last Edit: November 08, 2017, 09:10:56 PM by Ztrox93 »

Offline bombarta

  • Master Force User
  • *****
  • Posts: 1318
  • Impressive..... most Impressive!
Re: Prizm 5.1 Neopixel help.
« Reply #1 on: November 09, 2017, 03:40:46 AM »
Make sure your battery is fully charged if you haven't already.
Make sure there's no solder creeeping between any of the solder points.
Did you change any fonts on the sd card and if so did you format it first?
I don't know, i gotta bad feeling about this!
       

Offline Sethski

  • Master Force User
  • *****
  • Posts: 1141
Re: Prizm 5.1 Neopixel help.
« Reply #2 on: November 09, 2017, 04:11:39 AM »
The wiring looks like everything's going where it should, although there does look like quite a lot of solder and exposed wire up to the connection points in places, so potential for shorts from both of them, esp around the switch and transistor connections. Probably a good idea to desolder, trim the ends to be a bit shorter, clean up any excess solder with some copper braid and resolder. The usual PVC wire coating can be a pain as it shrinks back a bit and exposes wire with heat from the soldering iron, but you can always slip a short section of heatshrink tubing down over the wire to the connection afrer soldering to the board if you're finding this a problem.

The override txt file should be located in the main/root location, alongside the font folders (rather than in any of the individual font folders).

If you were to copy and paste the text of your override file, happy to look over it and chime in if I can see anything missing or that looks like it should be different.

Good luck! I think most folks can relate both to the disappointment of wiring stuff and nothing happens (like not making the jump to hyperspace type feeling) and the great feeling when you wire stuff up and switch it on for the first time and it does work. Hoping you have the second of those feelings very soon  :wink:

Offline Ztrox93

  • No Force
  • *
  • Posts: 6
  • Um...Hello?
Re: Prizm 5.1 Neopixel help.
« Reply #3 on: November 09, 2017, 07:14:32 AM »
Quote
Make sure your battery is fully charged if you haven't already.
Make sure there's no solder creeeping between any of the solder points.
Did you change any fonts on the sd card and if so did you format it first?

It was. I pulled it straight off the charger.

The solder work is definitely not the best. This is the smallest thing I have ever soldered on, and I was never the greatest at it. But I could not see anything that was touching something it wasn't. But I am going to triple check.

No the only thing I did on the SD card was change some parameters. I did not format anything, I didn't know that was necessary.

Thank you for your response!

Offline Ztrox93

  • No Force
  • *
  • Posts: 6
  • Um...Hello?
Re: Prizm 5.1 Neopixel help.
« Reply #4 on: November 09, 2017, 07:37:00 AM »
Quote

The wiring looks like everything's going where it should, although there does look like quite a lot of solder and exposed wire up to the connection points in places, so potential for shorts from both of them, esp around the switch and transistor connections. Probably a good idea to desolder, trim the ends to be a bit shorter, clean up any excess solder with some copper braid and resolder. The usual PVC wire coating can be a pain as it shrinks back a bit and exposes wire with heat from the soldering iron, but you can always slip a short section of heatshrink tubing down over the wire to the connection afrer soldering to the board if you're finding this a problem.

The override txt file should be located in the main/root location, alongside the font folders (rather than in any of the individual font folders).

If you were to copy and paste the text of your override file, happy to look over it and chime in if I can see anything missing or that looks like it should be different.

Good luck! I think most folks can relate both to the disappointment of wiring stuff and nothing happens (like not making the jump to hyperspace type feeling) and the great feeling when you wire stuff up and switch it on for the first time and it does work. Hoping you have the second of those feelings very soon  :wink:




Report to moderator    Logged

Unlike (You liked this)

Yeah it is definitely not the prettiest solder job ever. I'm not used to anything this small! I will re-do all of my connections and clean them up. Yeah I'm using 28g wire so as soon as a little heat is applied to eat, the plastic just runs from it. I didn't even think about protecting the leads, so I will do that!

This is the parameters I have for the Overide folder

Quote
## Override File

vol=4

beep=40

valsnd=0

deep=15000

muteoff=0

switch=2

offp=0

offd=200

gate=50

hclash=550

hswing=250

swing=250

clash=250

lockup=200

ledstrip=125

ls0=14

ls1=28

And this is the Parameters I have for the first profile folder.

Quote
// PRIZMv5 config

drive=0,0,1023

fdrive=1023,1023,1023

focmix=001

tridenton=0

tridentoff=0

tridentm=0000

tridentfx=0

tridentflk=0

resume=1

shmrd=80

shmrp=6

shmrr=12

shmr%=0,50

focd=150

focp=10

focr=10

foc%=0,50

qon=1000

qoff=1000

fade=0

flks=5

flkd=20

pulsed=0

pulsel=0

lsfadeon=1

lsfadeoff=1

lightstick=0

omnisabers=0

idlepulsing=15

idleled=0

You perfectly described what I am feeling, and I hope I feel accomplished very soon!

I cannot tell you how much I appreciate the information, and advice!

Offline Ztrox93

  • No Force
  • *
  • Posts: 6
  • Um...Hello?
Re: Prizm 5.1 Neopixel help.
« Reply #5 on: November 10, 2017, 10:26:59 AM »
Update:

 I figured out the problem!

 The battery holder I am using (http://www.thecustomsabershop.com/18...lder-P886.aspx) does not like to accept flat top 18650 batteries.

 I solved this issue by building the positive post on the holder with a fair amount of solder.

[Here is a picture of it in action!


Imgur: The most awesome images on the Internet

 So I have a question about the blade now. Is there a way to up the brightness of this? I can still see the LED's through the foam. I have not put it in the blade with the film yet. I was just curious of if there is a way to try to mask the LEDS a little better.

 My plan is to put the LED's and the foam into the blade, add the TCSS film, and sand the blade a little bit.

 Thoughts on this?

 Again thank you to everyone who helped make this work!

 I appreciate ya'll!