fiduciary

Author Topic: SwingBright configuration help please - Solved  (Read 439 times)

0 Members and 1 Guest are viewing this topic.

Offline MikeyX

  • Force User
  • ***
  • Posts: 204
  • Star Wars collector in the UK.
SwingBright configuration help please - Solved
« on: April 16, 2023, 04:29:18 AM »
I’m hoping someone can help me understand how to disable the SwingBright functionality on CFX FW v007f. Unfortunately I’m not on Facebook so cannot ask this on the Facebook support group (or see it as it’s a closed group) – so apologies if answers are already on there.

The issue I have is that the blade flashes with the FoC colour (rather than the ecolor) on a swing, and I simply can’t prevent this from happening. I feel like I must be missing something obvious, so hopefully it will be an easy answer!

The parameters I’ve tried changing to fix this:
•   I’ve set the ecolor to the same as the blade color in the colour profiles. My understanding was that swingbright used this FX color – but it still seems to use the FoC colour.
•   I’ve tried setting mapping_color=1 (heat mapping) and 0 (legacy mapping) as the manual implies this relates to FX colour blending.
•   I’ve tried mapping_sbright=0 (static) and 3 (motion) combined with settings for mapping_move as per below.
•   mapping_move -  I’ve tried numerous settings including 800,1023 and 1023,1023, and 0,0. These affect when/how much the flash happens, but the extreme settings don’t disable it.
•   I’ve tried both style_sbright=0 and 1. I even tried -1 in case that disabled it.

Changing other colours (e.g.dcolor for drag) works fine for those effects. I’m at a complete loss as to what to try next – the only fix I have at the moment is to downgrade to an earlier FW version.

Hopefully someone can spot what I’m missing / doing wrong, or provide some further explanation on how the SwingBright system works (I’ve mined the manual and changelog).

An example colour profile is below where I’ve set the color and ecolor the same – this flashes white on every swing.

##Red
[color=0]
color=1023,0,0,0
fcolor=1023,1023,1023,0
lcolor=1023,1023,1023,0
bcolor=1023,1023,1023,0
xcolor=1023,0,0,0
ecolor=1023,0,0,0
kcolor=1023,1023,1023,0
tcolor=1023,1023,1023,0
dcolor=1023,1023,1023,0
mcolor=1111
tridentm=0000
« Last Edit: April 16, 2023, 11:27:56 AM by MikeyX »

Offline MikeyX

  • Force User
  • ***
  • Posts: 204
  • Star Wars collector in the UK.
Re: SwingBright configuration help please - Solved
« Reply #1 on: April 16, 2023, 08:14:19 AM »
OK - think I may have solved it. I think the issue is actually that it was Flicker FX causing the flash. It was set to be triggered by the audio level and the swings were loud enough to trigger it at the peak making me think it was swing bright (doh!)

I just killed the flickeFX by setting force_flicker and depth_flicker to 0 and that prevented the flashing. More experimentation to get it how I like it - but think that was the root cause.

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4920
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: SwingBright configuration help please - Solved
« Reply #2 on: April 16, 2023, 11:00:14 PM »
indeed, swingbright doesn't affect your clash behavior, however the specific (ledstrip) flicker fx has the audio mapping and it will generate bursts of flicker (or increase its strength) based on audio volume, which is, as you experienced, louder with the clash occurring. Glad you solved it.
If you need a better / good overview of your current blade profile, use RICE, the fx selected as well as the mappings are clearly displayed in the drop down menus and it makes it easier to disable on the fly / in real time

 

retrousse