fiduciary

Author Topic: Drive Luxeon style LED off motor mount?  (Read 3724 times)

0 Members and 1 Guest are viewing this topic.

Offline Eomund

  • Padawan Learner
  • **
  • Posts: 58
Drive Luxeon style LED off motor mount?
« on: April 16, 2010, 09:55:42 AM »
I've heard that, theoretically, you can run a luxeon LED off the SaberSD via the rumble motor pad.  But has anyone actually done this?  I mean wouldn't it be a problem that the motor mount isn't polarized?

Offline Psab Keel

  • Master Force User
  • *****
  • Posts: 818
Re: Drive Luxeon style LED off motor mount?
« Reply #1 on: April 16, 2010, 11:37:47 AM »
I've never heard that before. 

Offline Matt Thorn

  • Experienced Force User
  • ****
  • Posts: 342
    • Köjin Köbö
Re: Drive Luxeon style LED off motor mount?
« Reply #2 on: April 16, 2010, 07:22:06 PM »
That doesn't make sense, since there wouldn't be a steady flow of current. It would make a lot more sense to just pair the SaberSD with a TCSS LED driver (momentary style) and use a momentary DPDT switch to turn them on and off simultaneously.
There's always a bigger fish.

Offline Eomund

  • Padawan Learner
  • **
  • Posts: 58
Re: Drive Luxeon style LED off motor mount?
« Reply #3 on: April 17, 2010, 10:01:58 AM »
That doesn't make sense, since there wouldn't be a steady flow of current. It would make a lot more sense to just pair the SaberSD with a TCSS LED driver (momentary style) and use a momentary DPDT switch to turn them on and off simultaneously.

Yeah, that's what I thought. Thanks for the input. I'll probably go with the TCSS driver solution.

Offline ARKM

  • Master Force User
  • *****
  • Posts: 935
Re: Drive Luxeon style LED off motor mount?
« Reply #4 on: February 19, 2011, 12:27:26 AM »
I know this is necroposting but I have some useful info to offer.  First of all, the vibration moter pads do have polarity.  The positive lead is marked on the board and in a pic inside the SaberSD's PDF manual.  Second, there are individual settings in the mode.txt file to supply juice to the vibration motor pads for hum, swing and clash.  Since the hum is constant with "vibwhilehum" set to 1 in the mode.txt file, the current is also constant (except during the swing and clash... which also supply current to the vibration motor pads).  Third, The voltage those pads put out is individually adjustable for hum, swing and clash.

I have sucessfully hooked up two die (in series) from a LEDEngin 10W Red to the vibration motor pads.  Works just fine.  The only concerns I have are "Will the 700ma current draw from the LED harm the board later on?" or "Do the pads even allow that much current draw in the first place?".  The two die seem very bright.  I guess I can use my multimeter to verify current draw, lol.
« Last Edit: February 21, 2011, 11:19:43 PM by ARKM »

Offline Darth Xusia

  • Master Force User
  • *****
  • Posts: 1255
  • "quit cher whinin' and just build some sabers"
Re: Drive Luxeon style LED off motor mount?
« Reply #5 on: February 19, 2011, 05:27:25 AM »
Does it not state the voltage and current output of the pads in the manual?
If not, how do you determine the correct resistor to use for the motor?
What I am getting at is, if it is a set (low) voltage and current, then you know if it can run a led or not. If it is just a feed through (straight from the batteries, which I doubt it is since it is adjustable) then it definitely run a led.
Thank you Photobucket for the best Sig ever!

Offline ARKM

  • Master Force User
  • *****
  • Posts: 935
Re: Drive Luxeon style LED off motor mount?
« Reply #6 on: February 19, 2011, 11:34:42 AM »
The max current output is not stated but voltage ouput is and the voltage output is adjustable in the mode.txt file.  The max voltage output that it can supply is supposedly the same as the max voltage ouput of your battery pack.  The minimum might be as low as .001 volts.  Not sure on that one but I'm pretty sure that it can at least go as low as 1.5V. as the manual states it can use 1.5V vibration motors.

NOTE:  The negative pad is what regulates voltage and the positive pad is always "live" even when the board is off.

The current flowing in an LED is an exponential function of voltage across the LED.  You don't need to know how much current is being put out by the vibration motor pads, only how much it will allow to be put out without harming the soundboard.

Using Ohm's law, you only need to know two of three variables to calculate the third.  Those variables being voltage, current and resistance.  If you supply the "correct" voltage to the device, and the "correct" resistance, it should only allow it to draw the "correct" current.  This means that you will need a resistor, even when supplying the LED's rated voltage.  When supplying the LEDs rated voltage, you would need a 1 Ohm resistor.

Some devices that provide electricity can only allow so much current through them so it is possible that the vibration motors on the pad will not allow enough current for the LEDs to light up at their standard operating efficiency.  This means that you can run an LED off of it with the correct voltage and with the correct resistor but still may not get the required current.  In that situation, the board's circuitry for the vibration motor pads is limiting the current flow.

I have not yet tested whether or not the vibration motor pads are putting out the correct current for the LED I am using.  Also, if the correct current can be drawn off of the vibration motor pads, is that current too much for the circuitry on the soundboard to handle long term?  Only Jim can answer that one.  I emailed him asking if it can handle 700ma.  Here's hoping he gets back to me soon and let's me know.

Edit:  Did some research on LEDs and resistance and corrected a lot of wrong info.  Sorry about that.
« Last Edit: February 21, 2011, 11:21:35 PM by ARKM »

Offline EXAR KUN

  • SITH/EMPIRE Master MODERATOR
  • Master Force User
  • **
  • Posts: 3098
  • Formerly known as SpaceWindu
    • My YouTube channel: youtube.com/spacewindu
Re: Drive Luxeon style LED off motor mount?
« Reply #7 on: February 22, 2011, 09:48:32 AM »
The smaller triangular battery pack that Hyperdyne sells is listed at 750 ma and the large stick battery is 1200 ma.

Since you can connect these batteries to the board with no problem, I would have to assume that 700 ma should be no problem for the board... but waiting for the official word from Jim is best.



Offline Darth Xusia

  • Master Force User
  • *****
  • Posts: 1255
  • "quit cher whinin' and just build some sabers"
Re: Drive Luxeon style LED off motor mount?
« Reply #8 on: February 22, 2011, 09:57:34 AM »
The smaller triangular battery pack that Hyperdyne sells is listed at 750 ma and the large stick battery is 1200 ma.

Since you can connect these batteries to the board with no problem, I would have to assume that 700 ma should be no problem for the board... but waiting for the official word from Jim is best.

Wouldn't that be mAh? That's not the same thing as mA.
Thank you Photobucket for the best Sig ever!

Offline ARKM

  • Master Force User
  • *****
  • Posts: 935
Re: Drive Luxeon style LED off motor mount?
« Reply #9 on: February 22, 2011, 03:22:20 PM »
Battery run time in listed milliamp hours which is abbreviated as mAh.  Current, when listed in milliamps, is abbreviated as mA.

I have yet to see a battery's current flow limitation listed on them.

Offline ARKM

  • Master Force User
  • *****
  • Posts: 935
Re: Drive Luxeon style LED off motor mount?
« Reply #10 on: February 22, 2011, 07:57:34 PM »
Just heard back from Jim...

The driving transistor for the vibration motor pads is rated at 600mA.  He said that it may allow 700mA or more... but stated that it will probably shorten the life of that component.  He doesn't know by how much the lifespan would be shortened.  So if you run your main LED off of the vibration motor pads, you should probably adjust the voltage and resistance so that you are only providing 600mA to the LED.  Sadly, this means that you will be underdriving it as most LEDs that are used for the main LED in a saber require 700mA or greater.

He also stated that one could replace the transistor with a logic level FET that has a greater current limit but that's way above my skill level, lol.
« Last Edit: February 22, 2011, 07:59:58 PM by ARKM »