fiduciary

Author Topic: CFX and LED strip config questions  (Read 163 times)

0 Members and 1 Guest are viewing this topic.

Offline Deadguy11

  • No Force
  • *
  • Posts: 8
  • Um...Hello?
CFX and LED strip config questions
« on: February 10, 2021, 07:54:10 AM »
So this may take me a bit to explain. Hopefully people don't go TLDR on me.

I have been working on an Obi-wan Kenobi EP3 character blade and I am not sure if I have my config.txt, led.txt and font_config.txt file setup correctly. I realize that a CFX can handle numerous color profiles and blade profiles, but frankly, that doesn't matter to me right now.

All I want is 1 profile, 1 color and using The_Negotiator .wav files that came with the CFX, working perfectly with movement technology in the CFX.

So the blade "works". Blade, power on, power off, FoC, etc. But there are some things that aren't "right", and I can only assume it will take a bunch of tweaking to get it right. I just have no idea what to tweak. If someone has a really good config.txt, led.txt and colors.txt file for an Obi-wan Kenobi EPS character blade, I would gladly just take them to use. But I would like to understand what's happening.

The important hardware parts
Korbanth K4v2 hilt
Goth-3DDesigns K4-Padawan Var2 https://www.shapeways.com/product/63T9VDW2V/89sabers-k4-padawan-var2?optionId=84715902&li=shops
Crystal Focus 10 sound board
RGBW 144 LED strip x2 https://www.amazon.com/gp/product/B01MYV70QZ/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&th=1

MY CONCERNS
1. Blade color. The Blue color of the blade seems to be much weaker than the Red or the Green. I don't seem to be able to get an actual BLUE color. I get more of an Ice Blue or Cyan or starts toward Purple. Whether I am using one of the 30+ color profiles that came with the CFX or I am using the R.I.C.E to manually adjust the color.

Does it have to do with using RBGW LED strips instead of RBG? I don't completely understand what needs to be different between an RBG and and RBGW led strip. If the details of the text files below are correct, could the Blue LEDs in the strips I have just not be that great?
(Is this correct from the config.txt file?)
strippower=1111
ls1_timings=350,700,24,1,4
ls2_timings=350,700,24,1,4
(Is this correct from the colors.txt file?)
//Royal Blue
[color=26]
color=0,0,1023,0
fcolor=1023,1023,1023,0
lcolor=1023,1023,1023,0
bcolor=1023,1023,1023,0
xcolor=1023,0,0,0
ecolor=1023,1023,1023,0
kcolor=1023,1023,1023,0
tcolor=1023,1023,1023,0
dcolor=1023,1023,1023,0
mcolor=1111
tridentm=0000

If it is the strips just having an overall weak Blue LED color, is there anything I can do about it? Could I use a Day Blade, Trans Blue or Enhanced Blue blade to "correct" the color?
Such as:
https://www.thecustomsabershop.com/1-Thin-walled-Trans-Blue-PolyC-40-long-P1081.aspx
Or
https://www.thecustomsabershop.com/1-Thin-Walled-Enhanced-Blue8482-PolyC-40-long-P1196.aspx
Or
https://kyberlight.com/blades/kyberlight-day-blades-36.html


2. SmoothSwing settings. The K4-Padawan chassis places the sound board almost dead center of the hilt. I have mine wired with the micro SD card on top, facing the rear of the hilt. So Bottom-Front orientation (2) or orient=2 in the config.txt file, Correct? But the smooth swing just seems off. I have seen Erv's video as well as several others using a CFX and their movements/sound with the blade is SUPERB! So I know it is the settings on mine. I just have no idea what to do.

config.txt
## Motion Settings
gate=50
smooth_gate=50
hclash=850
hswing=450
hslash=400
hhybrid=550
hforce=300
hfclash=650
hstab=500,-20,20
hspin=750
htwist=350
hdrag=500,-90,0
htemp=40
spectrum_mode=0
spectrum_axis=0
field=10,10,10

font_config.txt
## SMOOTHSWING parameters
smooth_sharp=3.0
smooth_gain=100
smooth_width1=45
smooth_width2=160
smooth_sens=250
smooth_physics=950
smooth_dampen=80
smooth_mode=2

Any assistance would be really appreciated!


Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4814
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: CFX and LED strip config questions
« Reply #1 on: February 10, 2021, 08:09:57 AM »
those are my settings as well, I use the default in the video.

I don't like the RGBW much, I think you should be able to get a proper Obi blue with RGB strips, all you need is experimenting in real time with RICE to select your color (not sure you have tried to adjust your saber with RICE yet)

Flash on Clash : if legacy FoC is desired, adjust (and understand) Foc And Shimmer timelines (complete section in the manual about this) and Foc Color. Other Foc Styles have been added as well (foc fade for instance)


Offline Deadguy11

  • No Force
  • *
  • Posts: 8
  • Um...Hello?
Re: CFX and LED strip config questions
« Reply #2 on: February 10, 2021, 09:33:24 AM »
Erv,

I have used RICE to try and get the color to a proper Obi blue, couldnt get it to a proper color. But I am definitely going to try again.

Updated to the latest firmware after posting and I had been using the latest smoothed cfx SD files.

And it is the smooth swing not the FoC that I am having trouble with. Just a simple bit of saber twirling, doesnt change from the swing to the smoothswing. At least that is what I think is happening.

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4814
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: CFX and LED strip config questions
« Reply #3 on: February 10, 2021, 10:06:23 AM »
ensure your font is smoothswing
as for color, well if the strips aren't producing the color, your might need to get some different ones

Offline Deadguy11

  • No Force
  • *
  • Posts: 8
  • Um...Hello?
Re: CFX and LED strip config questions
« Reply #4 on: February 10, 2021, 11:17:05 AM »
Checking on the smoothswing fonts.

Any suggestions on the leds?

Offline scott

  • Experienced Force User
  • ****
  • Posts: 325
  • Oh, I don’t think so.
Re: CFX and LED strip config questions
« Reply #5 on: February 10, 2021, 07:30:15 PM »
Let’s us know on the font package...per your DM to me, I suspect you just need to grab the polyphonic font from the sub folder in the default package.

As far as the blade, while you asked about different tubes, you didn’t specify which one you are using. If it’s trans white, you are good and it isn’t the tube.  As erv mentioned, most of our configs are RGB, not RGBW...and TCSS strips that I have purchased are RGB.  I

Offline erv

  • Plecter Labs Inc. "Keeper of the Buttered Toast"
  • Manufacturer
  • Master Force User
  • *
  • Posts: 4814
  • Formerly known as Irvin PLECTER
    • Plecter Labs - Props Electronics
Re: CFX and LED strip config questions
« Reply #6 on: February 10, 2021, 10:12:36 PM »
Let’s us know on the font package...per your DM to me, I suspect you just need to grab the polyphonic font from the sub folder in the default package.

they are a now all smoothswing and all versions are exposed in the root directory (default package). 16 fonts total